Siberian server requirements

Here are the software and hardware requirements to run Siberian properly:

Software requirements:

  • Supported OS: Linux (Centos 7 or newer, Debian 8 or newer, Ubuntu 16 or newer, Fedora 25 or newer).
  • Supported server: Apache 2 or newer
  • PHP 5.6 to PHP 7.0
  • MySQL 5.5 or newer
  • PHP extensions: GD, PDO MySQL, SimpleXML, Curl, DOM, iconv, mbstring, mod_rewrite.
  • PHP settings (php.ini) :
    • functions: exec() , allow url_fopen
    • memory_limit=512M
    • upload_max_filesize=100M
    • post_max_size=100M
  • Zip
  • Unzip
  • OpenSSL 1.0.1 minimum
  • php-sqlite3
  • glibc >= 2.14
  • Recommended: Try to get a control panel with your server, like cPanel or Parallel Plesk panel. Install the panel before to install Siberian.
  • For apk generator :
    • Linux 64 bits distribution
    • Java 1.8+

Hardware requirements:

Single-App Edition (SAE):

  • A shared server with a CPU from 1vCore.
    (Please note there is an issue with Hostgator shared servers: there is a timeout setting which is made by default by Hostgator and that cannot be changed on a shared server. So Siberian is not compatible with these Hostgator shared servers.)

Multi-Apps Edition (MAE):

  • Type of server: Virtual Private Server (VPS) or Dedicated Server (no Shared servers)
  • SSH Root access for technical support
  • CPU: From 1vCore
  • RAM memory: From 4GB
  • Disk space: From 20GB
  • Bandwidth: From 100Mbs or from 1TB of bandwidth per month.

Platform Edition (PE):

  • Type of server: Virtual Private Server (VPS) or Dedicated Server (no Shared servers).
  • SSH Root access for technical support
  • CPU: From 2vCore
  • RAM memory: From 4GB
  • Disk space: From 20GB
  • Bandwidth: From 100Mbs or from 1TB of bandwidth per month.

Recommended VPS for MAE and PE:

We recommend usually the VPS provided by OVH (SSD 2 at least) or Contabo (VPS M at least) because they represent the best quality-price ratio:

This way your server will be completely set up and ready to host your Siberian edition.

 

NOTE FOR WHM/CPANEL  USERS : 

To avoid some issues and complex configurations and settings, please create an account specifically for Siberian, do not install Siberian in a sub-domain of an existing account.

 

Was this article helpful?

Related Articles